Question:

Unable to use -o allow_other with sshfs (option enabled in fuse.conf)

Isabella: 02 February 2022

I have the following on my /etc/fuse.conf file:

# Set the maximum number of FUSE mounts allowed to non-root users.                       
# The default is 1000.                                                                   
#                                                                                        
#mount_max = 1000                                                                        

# Allow non-root users to specify the 'allow_other' or 'allow_root'                      
# mount options.                                                                         
#                                                                                        
user_allow_other    

But when I try to mount a remote path with the option allow_other:

> sshfs name@server:/remote/path /local/path -o allow_other

I get:

fusermount: failed to open /etc/fuse.conf: Permission denied
fusermount: option allow_other only allowed if 'user_allow_other' is set in /etc/fuse.conf

I have triple checked and the option user_allow_other is uncommented in my fuse.conf,as I copied above.

I have also executed sudo adduser my_user_name fuse (not sure if this is needed though), but I still get the same problem.

Why is it not parsing the /etc/fuse.conf file correctly?

Answer:
Muhammad: 02 February 2022

Given the message failed to open /etc/fuse.conf: Permission denied, I suggest

chmod a+r /etc/fuse.conf