Unix & Linux

vim install on freebsd has taken 5 hours and counting

Ok, so installed portmaster (http://www.freshports.org/ports-mgmt/portmaster) and I'm trying with it, I'm hoping it won't take time. So I've been up all night and my vim installation is still going on. I have an amazon ec2 freebsd server setup. I was hoping to setup jails, which took 4-5 hours to make ....

Piper Piper: 02 February 2022

Unix & Linux

How to mass rename files with ill-formed numbering?

I've got bunch of files with ill-formed numbering: prefix-#.ext | for files with number 1-9 prefix-##.ext | for files with number 10-99 prefix-###.ext | for files with number 100-999 Due to further processing I need all of their names to be in format: prefix-###.ext. Is there any easy way to ....

Aria Aria: 02 February 2022

Unix & Linux

Routing on Centos 7.3 to Internet

I have look for, but all I tried, doesn't work I have two machines with Centos, Machine 1 with a enp0s3 (192.168.56.99 IP), and the Machine 2 with (enp0s8 192.168.56.101 and enp0s3 10.0.2.15 IPs). As you can see, my internal network is the 192.168.56.0/24, and I want to connect the ....

Liam Liam: 02 February 2022

Unix & Linux

SELinux blocks tomcat web application to load Java native library (JNI) from /tmp folder

I have a Centos 7 with Tomcat installed and tomcat user ls -l /var/lib/tomcat total 0 drwxrwxrwx. 5 root tomcat 84 Jul 3 13:18 webapps SELinux is enforcing and a Java web application which tries to load Java native library (JNI) from shared object files .so in /tmp/ folder cannot ....

Layla Layla: 02 February 2022

Unix & Linux

Fake installation of java-runtime package?

I don't use openjdk environment, and I've got oracle java installed, then linked the java / javac binaries to /usr/bin. Now when I build packages that requires java-runtime package, I had to edit the PKGBUILD everytime to strip off the dependency of that package. So, can I insert a record ....

Mia Mia: 02 February 2022

Unix & Linux

Build gdal with mrsid DSDK on fedora 21

I'm trying to build gdal 1.11.2 from source with mrsid DSDK enabling gdal to able to read mrsid file. I did all the required things and after I run make it shows me the following error message: GNUmakefile:46: recipe for target 'gdalinfo' failed make: *** Error 1 make: Leaving directory ....

Leah Leah: 02 February 2022

Unix & Linux

How to increase space allocated for linux

I am using Linux mint and at the time of installation I allocated 2GB space for file root of Linux. Now I need more space for Linux I tried to do it via gparted. But I can't figure out how to do it. ....

Addison Addison: 02 February 2022

Unix & Linux

egrep doesn't work as expected on SunOS system

Here is what I want to achieve on SunOS: Only pattern like , , or text are valid patterns, where by text I mean anything in 0-9,a-z,A-Z, space, newline, tab, enter. Anything other than this is invalid pattern. i.e egrep -v should capture it. Patterns like , ]], should also ....

Paisley Paisley: 02 February 2022

Unix & Linux

How do I stop ssh-agent trying all keys with agent forwarding?

Often I'll connect via SSH to VM instances to deploy code from private Bitbucket repositories, cloning repositories via git over SSH. Today I was getting the error: conq: repository access denied. deployment key is not associated with the requested repository. A quick search showed it was the problem described in ....

Landon Landon: 02 February 2022

Unix & Linux

Shell: Check line format file and loop over file lines

I need to check 2 assetions: The file content format Iterate over that content: So, the content file must be: key1=value key2=value2 ... So, each line must have the format key=value. Spaces are not allowed before or after the =. This file content has to be an env format file. ....

Thomas Thomas: 02 February 2022