Ubuntu

ack-grep: command not found after upgrade to Ubuntu 18.04

sudo apt-get install ack-grep gives ack-grep is already the newest version (2.22-1) but ack-grep gives ack-grep: command not found It was working fine in Ubuntu 16.04, before upgrading to 18.04 ....

Natalia Natalia: 02 February 2022

Ubuntu

How can I configure a computer to connect to the internet through another computer that has two NICs?

I use a hard wired connection from my box to my router, I have an older system without a wireless card and want to run it ad hoc. My master box is a Dell Optiplex gx270 running Ubuntu 12.04. The box I want to connect through it is an HP ....

Abigail Abigail: 02 February 2022

Ubuntu

dpkg -L not showing all files of package

I am trying to find files installed from libboost-all-dev (https://packages.ubuntu.com/disco/libboost-all-dev) using dpkg, but it does not work. First, an indication of that I have installed the package: $ find /usr/lib/ -name '*boost*sys*' /usr/lib/x86_64-linux-gnu/libboost_filesystem.so.1.67.0 /usr/lib/x86_64-linux-gnu/libboost_filesystem.a /usr/lib/x86_64-linux-gnu/libboost_filesystem.so /usr/lib/x86_64-linux-gnu/libboost_system.so.1.67.0 /usr/lib/x86_64-linux-gnu/libboost_system.a /usr/lib/x86_64-linux-gnu/libboost_system.so Now running: $ dpkg -l boost dpkg-query: no packages found matching boost ....

Lincoln Lincoln: 02 February 2022

Ubuntu

Restart systemd service on file change?

I'm new to systemd and would like to know what is the best strategy for restarting my web application whenever I deploy new version. Currently I start my service on boot and it just sits there, however I would like it to restart automatically whenever I change the files since ....

Ava Ava: 02 February 2022

Ubuntu

What do these two screens mean and how to remove them?

I am new to ubuntu On the right it shows two screens I accidentally opened two screens on the same desktop. They are visible on the right. I can see this on pressing the activities button on the top left. I want to know to create and especially delete this. ....

Nova Nova: 02 February 2022

Ubuntu

Where does sshd default configuration come from?

After a fresh install every option of the default configuration file in /etc/ssh/sshd_config commented out. But when I run /usr/sbin/sshd -tT, there are many option actually to see. Where are those came from? Related: https://stackoverflow.com/questions/38570371/sshd-config-all-parameters-commented-out ....

Landon Landon: 02 February 2022

Ubuntu

Can't connect to Facebook on 13.10

For a few days I haven't been able to connect to Facebook. this is not a browser specific problem because if I ping www.facebook.com i get: PING star.c10r.facebook.com (31.13.84.8) 56(84) bytes of data. ping: sendmsg: Operation not permitted ping: sendmsg: Operation not permitted ping: sendmsg: Operation not permitted I tried ....

Owen Owen: 02 February 2022

Ubuntu

Problem using Virtual Terminal

How can I copy-paste following command: rm -r ~/.gconf/apps/gnome-terminal gconftools --recursive-unset /apps/gnome-terminal into a virtual-terminal? ....

Serenity Serenity: 02 February 2022

Ubuntu

What kind of scheduling algorithms are used in 15.04? Is it possible to change it?

Would like to know what scheduling mechanisms is employed in 15.04, time-sharing or real-time, I'm pretty sure its FIFO, Round Robin, SJF? P.S: New to Linux ....

Amir Amir: 02 February 2022

Ubuntu

Understand free command with top command

I have a doubt. I start ubuntu and run free command. I will get the total free space available. Let say it as 100MB. Now I run a few applications. So after some time, I again run the free command. Now it is 80MB.. The total used memory is 20MB. ....

Emilia Emilia: 02 February 2022